Gephi on Mac OS X

Original Post:
https://github.com/gephi/gephi/issues/748#issuecomment-42905181

This took me a while as well :-/
As this is a show-stopper for every normal Mac user here the steps to get it running on Mac OS X 10.9:

download and install this: http://support.apple.com/kb/DL1572
delete your gephi settings dir: rm -r ~/Library/Application\ Support/gephi
find your java home with /usr/libexec/java_home -v 1.6, it should print something like /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
if there is a message about being unable to find any JVMs matching version 1.6 something is wrong, fix it
edit /Applications/Gephi.app/Contents/Resources/gephi/etc/gephi.conf to set your jdkhome e.g. like this: echo “jdkhome=\"$(/usr/libexec/java_home -v 1.6)\"" >> /Applications/Gephi.app/Contents/Resources/gephi/etc/gephi.conf
start gephi and open the Les Miserables sample, if you see the graph good.
check gephi’s about for the line saying Java: 1.6.0_65; Java HotSpot(TM) 64-Bit Server VM 20.65-b04-462
as simple as that ^^

This critical bug was reported over a year ago… Until Java 7 is supported I suggest solving it similar to other apps like yEd by a dialog guiding the user through the installation of Java 6.
In the meantime please just check the Java Version on startup and properly explain the problem and how to solve it instead of that ugly nothing saying “unable to load libjogl_awt" error message.

We all like gephi, but due to this i guess only < 1 % of your mac users are left 😦

發表迴響

在下方填入你的資料或按右方圖示以社群網站登入:

WordPress.com 標誌

您的留言將使用 WordPress.com 帳號。 登出 /  變更 )

Google photo

您的留言將使用 Google 帳號。 登出 /  變更 )

Twitter picture

您的留言將使用 Twitter 帳號。 登出 /  變更 )

Facebook照片

您的留言將使用 Facebook 帳號。 登出 /  變更 )

連結到 %s